summaryrefslogtreecommitdiffstats
path: root/lass/2configs/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/git.nix')
-rw-r--r--lass/2configs/git.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/lass/2configs/git.nix b/lass/2configs/git.nix
index 829e62269..caa7c3065 100644
--- a/lass/2configs/git.nix
+++ b/lass/2configs/git.nix
@@ -38,6 +38,10 @@ let
cgit.desc = "take a description of your disk layout and produce a format script";
cgit.section = "software";
};
+ krebspage = {
+ cgit.desc = "homepage of krebs";
+ cgit.section = "configuration";
+ };
news = {
cgit.desc = "take a rss feed and a timeout and print it to stdout";
cgit.section = "software";
@@ -100,10 +104,12 @@ let
# TODO make nick = config.krebs.build.host.name the default
nick = config.krebs.build.host.name;
channel = "#xxx";
+ # TODO define refs in some kind of option per repo
+ refs = [
+ "refs/heads/master"
+ ];
server = "irc.r";
verbose = config.krebs.build.host.name == "prism";
- # TODO define branches in some kind of option per repo
- branches = [ "master" ];
};
};
};
@@ -121,10 +127,13 @@ let
# TODO make nick = config.krebs.build.host.name the default
nick = config.krebs.build.host.name;
channel = "#xxx";
+ # TODO define refs in some kind of option per repo
+ refs = [
+ "refs/heads/master"
+ "refs/heads/staging*"
+ ];
server = "irc.r";
verbose = false;
- # TODO define branches in some kind of option per repo
- branches = [ "master" "staging*" ];
};
} // hooks;
};