summaryrefslogtreecommitdiffstats
path: root/lass/2configs/baseX.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/baseX.nix')
-rw-r--r--lass/2configs/baseX.nix55
1 files changed, 17 insertions, 38 deletions
diff --git a/lass/2configs/baseX.nix b/lass/2configs/baseX.nix
index a8bb8693f..9712bafff 100644
--- a/lass/2configs/baseX.nix
+++ b/lass/2configs/baseX.nix
@@ -7,9 +7,9 @@ in {
./mpv.nix
./power-action.nix
./copyq.nix
- ./xresources.nix
./livestream.nix
./dns-stuff.nix
+ ./urxvt.nix
{
hardware.pulseaudio = {
enable = true;
@@ -41,6 +41,11 @@ in {
default = "-*-clean-*-*-*-*-*-*-*-*-*-*-iso10646-1";
};
};
+ config.services.xresources.resources.X = ''
+ *.font: ${config.lass.fonts.regular}
+ *.boldFont: ${config.lass.fonts.bold}
+ *.italicFont: ${config.lass.fonts.italic}
+ '';
}
];
@@ -64,9 +69,11 @@ in {
dic
dmenu
gi
+ git-preview
gitAndTools.qgit
- lm_sensors
haskellPackages.hledger
+ lm_sensors
+ mpv-poll
much
ncdu
nix-repl
@@ -74,21 +81,20 @@ in {
pavucontrol
powertop
push
+ rxvt_unicode_with-plugins
+ screengrab
slock
sxiv
+ termite
xclip
xorg.xbacklight
xorg.xhost
xsel
- zathura
-
- mpv-poll
- yt-next
-
youtube-tools
+ yt-next
+ zathura
- rxvt_unicode
- termite
+ cabal2nix
];
fonts.fonts = with pkgs; [
@@ -98,42 +104,15 @@ in {
xlibs.fontschumachermisc
];
+ lass.xserver.enable = true;
services.xserver = {
- enable = true;
-
- desktopManager.xterm.enable = false;
- desktopManager.default = "none";
- displayManager.lightdm.enable = true;
- displayManager.lightdm.autoLogin = {
- enable = true;
- user = "lass";
- };
- windowManager.default = "xmonad";
- windowManager.session = [{
- name = "xmonad";
- start = ''
- ${pkgs.xorg.xhost}/bin/xhost +LOCAL:
- ${pkgs.xmonad-lass}/bin/xmonad &
- waitPID=$!
- '';
- }];
-
layout = "us";
xkbModel = "evdev";
xkbVariant = "altgr-intl";
xkbOptions = "caps:backspace";
};
- services.logind.extraConfig = ''
- HandleLidSwitch=ignore
- '';
-
- services.xserver.synaptics = {
- enable = true;
- twoFingerScroll = true;
- accelFactor = "0.035";
- };
-
services.urxvtd.enable = true;
+ services.xresources.enable = true;
lass.screenlock.enable = true;
}