summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/mors.nix')
-rw-r--r--lass/1systems/mors.nix57
1 files changed, 55 insertions, 2 deletions
diff --git a/lass/1systems/mors.nix b/lass/1systems/mors.nix
index f6ac1b4e6..9f492e2c6 100644
--- a/lass/1systems/mors.nix
+++ b/lass/1systems/mors.nix
@@ -20,12 +20,12 @@
../2configs/git.nix
#../2configs/wordpress.nix
../2configs/bitlbee.nix
- ../2configs/firefoxPatched.nix
+ #../2configs/firefoxPatched.nix
../2configs/skype.nix
../2configs/teamviewer.nix
../2configs/libvirt.nix
../2configs/fetchWallpaper.nix
- ../2configs/buildbot-standalone.nix
+ #../2configs/buildbot-standalone.nix
{
#risk of rain port
krebs.iptables.tables.filter.INPUT.rules = [
@@ -97,6 +97,54 @@
# { predicate = "-i retiolum -p tcp --dport 80"; target = "ACCEPT"; precedence = 9998; }
# ];
#}
+ {
+ containers.pythonenv = {
+ config = {
+ services.openssh.enable = true;
+ users.users.root.openssh.authorizedKeys.keys = [
+ config.krebs.users.lass.pubkey
+ ];
+
+ environment = {
+ systemPackages = with pkgs; [
+ git
+ libxml2
+ libxslt
+ libzip
+ python27Full
+ python27Packages.buildout
+ stdenv
+ zlib
+ ];
+
+ pathsToLink = [ "/include" ];
+
+ shellInit = ''
+ # help pip to find libz.so when building lxml
+ export LIBRARY_PATH=/var/run/current-system/sw/lib
+ # ditto for header files, e.g. sqlite
+ export C_INCLUDE_PATH=/var/run/current-system/sw/include
+ '';
+ };
+
+ };
+ };
+ }
+ {
+ services.mysql = {
+ enable = true;
+ package = pkgs.mariadb;
+ rootPassword = "<secrets>/mysql_rootPassword";
+ };
+ }
+ {
+ services.elasticsearch = {
+ enable = true;
+ plugins = [
+ pkgs.elasticsearchPlugins.elasticsearch_kopf
+ ];
+ };
+ }
];
krebs.build.host = config.krebs.hosts.mors;
@@ -170,6 +218,11 @@
device = "/dev/big/public";
fsType = "ext4";
};
+
+ "/mnt/conf" = {
+ device = "/dev/big/conf";
+ fsType = "ext4";
+ };
};
services.udev.extraRules = ''