summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/default.nix')
-rw-r--r--krebs/2configs/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/krebs/2configs/default.nix b/krebs/2configs/default.nix
index e7ece87b6..90aaa254a 100644
--- a/krebs/2configs/default.nix
+++ b/krebs/2configs/default.nix
@@ -4,7 +4,15 @@ with import <stockholm/lib>;
{
imports = [
./backup.nix
+ (let ca-bundle = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt"; in {
+ environment.variables = {
+ CURL_CA_BUNDLE = ca-bundle;
+ GIT_SSL_CAINFO = ca-bundle;
+ SSL_CERT_FILE = ca-bundle;
+ };
+ })
];
+ krebs.announce-activation.enable = true;
krebs.enable = true;
krebs.tinc.retiolum.enable = true;