summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/bln/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/1systems/bln/hardware-configuration.nix')
-rw-r--r--jeschli/1systems/bln/hardware-configuration.nix20
1 files changed, 11 insertions, 9 deletions
diff --git a/jeschli/1systems/bln/hardware-configuration.nix b/jeschli/1systems/bln/hardware-configuration.nix
index 714162271..2b354190c 100644
--- a/jeschli/1systems/bln/hardware-configuration.nix
+++ b/jeschli/1systems/bln/hardware-configuration.nix
@@ -8,27 +8,29 @@
[ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
];
- boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" "rtsx_pci_sdmmc" ];
+ boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sr_mod" "rtsx_pci_sdmmc" ];
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
+ boot.initrd.luks.devices.crypted.device = "/dev/disk/by-uuid/25534522-5748-4dcc-a5ca-80a3ac70f59d";
+
fileSystems."/" =
- { device = "/dev/disk/by-uuid/02144ea4-947d-440e-bbf9-99cab0dccf05";
+ { device = "/dev/disk/by-uuid/496c8889-96db-446d-9bac-60d4347faeac";
fsType = "ext4";
};
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/f169fd32-bf96-4da0-bc34-294249ffa606";
- fsType = "ext2";
- };
-
fileSystems."/home" =
- { device = "/dev/disk/by-uuid/68ef2163-7b3d-4dbb-add9-d3543ad7c738";
+ { device = "/dev/disk/by-uuid/2785adf5-a99e-49d7-86d6-99f393f457ea";
fsType = "ext4";
};
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/927E-01A0";
+ fsType = "vfat";
+ };
+
swapDevices = [ ];
- nix.maxJobs = lib.mkDefault 4;
+ nix.maxJobs = lib.mkDefault 8;
powerManagement.cpuFreqGovernor = "powersave";
}