summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/bln/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/1systems/bln/config.nix')
-rw-r--r--jeschli/1systems/bln/config.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/jeschli/1systems/bln/config.nix b/jeschli/1systems/bln/config.nix
index 885307b7a..6142933f5 100644
--- a/jeschli/1systems/bln/config.nix
+++ b/jeschli/1systems/bln/config.nix
@@ -3,12 +3,13 @@
# and in the NixOS manual (accessible by running ‘nixos-help’).
{ config, lib, pkgs, ... }:
-
+# bln config file
{
imports =
[ # Include the results of the hardware scan.
<stockholm/jeschli>
<stockholm/jeschli/2configs/virtualbox.nix>
+ <stockholm/jeschli/2configs/urxvt.nix>
./hardware-configuration.nix
# ./dcso-vpn.nix
];
@@ -16,10 +17,18 @@
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
+ jeschliFontSize = 20;
+ # Use the GRUB 2 boot loader.
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ # boot.loader.grub.efiSupport = true;
+ # boot.loader.grub.efiInstallAsRemovable = true;
+ # boot.loader.efi.efiSysMountPoint = "/boot/efi";
+ # Define on which hard drive you want to install Grub.
environment.shellAliases = {
n = "nix-shell";
- gd = "cd /home/jeschli/go/src/gitlab.dcso.lolcat";
- gh = "cd /home/jeschli/go/src/github.com";
+ gd = "cd /home/markus/go/src/gitlab.dcso.lolcat";
+ gh = "cd /home/markus/go/src/github.com";
stocki = pkgs.writeDash "deploy" ''
cd ~/stockholm
LOGNAME=jeschli exec nix-shell -I stockholm="$PWD" --run 'deploy --system="bln"'
@@ -33,6 +42,7 @@
nixpkgs.config.allowUnfree = true;
environment.variables = { GOROOT= [ "${pkgs.go.out}/share/go" ]; };
environment.systemPackages = with pkgs; [
+ termite
# system helper
ag
copyq
@@ -57,6 +67,7 @@
chromium
google-chrome
# programming languages
+ elmPackages.elm
go
gcc
ghc