summaryrefslogtreecommitdiffstats
path: root/tv/2configs/xp-332.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-10-07 11:41:44 +0200
committerlassulus <lass@blue.r>2018-10-07 11:41:44 +0200
commitee07881154f247d792e9121f3eb1c1b1275cd938 (patch)
treef048764fe696907d23c680cff44b695fccb27fb8 /tv/2configs/xp-332.nix
parentea82a695cf7895bd607cec4b5b80f3f90e736ce1 (diff)
parent5641a6ad03baccf299be6574193a37dd16e17137 (diff)
Merge remote-tracking branch 'ni/master' into 18.09
Diffstat (limited to 'tv/2configs/xp-332.nix')
-rw-r--r--tv/2configs/xp-332.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/tv/2configs/xp-332.nix b/tv/2configs/xp-332.nix
new file mode 100644
index 000000000..627401dc6
--- /dev/null
+++ b/tv/2configs/xp-332.nix
@@ -0,0 +1,45 @@
+with import <stockholm/lib>;
+{ config, pkgs, ... }: {
+
+ environment.etc."utsushi.conf".text = ''
+ [devices]
+ dev1.udi = esci:networkscan://EPSON79678C.fritz.box:1865
+ dev1.model = XP-332
+ dev1.vendor = EPSON
+ '';
+
+ hardware.sane = {
+ enable = true;
+ extraBackends = [
+ pkgs.utsushi
+ ];
+ };
+
+ krebs.nixpkgs.allowUnfreePredicate = pkg:
+ elem (parseDrvName pkg.name).name [ "imagescan-plugin-networkscan" ];
+
+ nixpkgs.overlays = singleton (self: super: {
+ utsushi = super.utsushi.override {
+ guiSupport = false;
+ jpegSupport = false;
+ networkSupport = true;
+ ocrSupport = false;
+ saneSupport = true;
+ tiffSupport = true;
+
+ logCategory = "ALL";
+ logLevel = "BRIEF";
+ };
+ });
+
+ services = {
+ printing = {
+ drivers = [
+ pkgs.epson-escpr
+ ];
+ enable = true;
+ };
+ saned.enable = true;
+ };
+
+}