summaryrefslogtreecommitdiffstats
path: root/tv/2configs/ssh.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-07-23 19:21:23 +0200
committerlassulus <lass@aidsballs.de>2016-07-23 19:21:23 +0200
commitf978c5312e1f88dd936495ff0fcd3a3aa032d90f (patch)
tree56e10a2cf4ced3d18d4ee8bfd4ba066e42a079d2 /tv/2configs/ssh.nix
parent29ef105c46287bb9964269004a56c51d4a2834bd (diff)
parentc546bc8c2dc1ec0fa120c79df3de4d977ce322ed (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'tv/2configs/ssh.nix')
-rw-r--r--tv/2configs/ssh.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/tv/2configs/ssh.nix b/tv/2configs/ssh.nix
new file mode 100644
index 000000000..7bf583426
--- /dev/null
+++ b/tv/2configs/ssh.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ # Override NixOS's "Allow DSA keys for now."
+ environment.etc."ssh/ssh_config".text = mkForce ''
+ AddressFamily ${if config.networking.enableIPv6 then "any" else "inet"}
+
+ ${optionalString config.programs.ssh.setXAuthLocation ''
+ XAuthLocation ${pkgs.xorg.xauth}/bin/xauth
+ ''}
+
+ ForwardX11 ${if config.programs.ssh.forwardX11 then "yes" else "no"}
+
+ ${config.programs.ssh.extraConfig}
+ '';
+
+ programs.ssh = {
+ extraConfig = ''
+ UseRoaming no
+ '';
+ startAgent = false;
+ };
+}