summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/w110er.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-01-06 21:27:05 +0100
committermakefu <github@syntax-fehler.de>2018-01-06 21:27:05 +0100
commit3aaab59b7f2eaa635106826bd4a4229a0a7a794c (patch)
tree5588d5b2fb3e416bba13473c5fbcfcccf3c7930d /tv/2configs/hw/w110er.nix
parent149aad4cb79de44e095b82ffdf7fa65cc95c2f93 (diff)
parentacecab429219d9086e23fa8912ecb05c017211d1 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'tv/2configs/hw/w110er.nix')
-rw-r--r--tv/2configs/hw/w110er.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tv/2configs/hw/w110er.nix b/tv/2configs/hw/w110er.nix
index 787bfc6e9..55e9482d4 100644
--- a/tv/2configs/hw/w110er.nix
+++ b/tv/2configs/hw/w110er.nix
@@ -1,8 +1,20 @@
+with import <stockholm/lib>;
{ pkgs, ... }:
{
imports = [
../smartd.nix
+ {
+ # nvidia doesn't build despite
+ # https://github.com/NixOS/nixpkgs/issues/33284
+ #hardware.bumblebee.enable = true;
+ #hardware.bumblebee.group = "video";
+ #hardware.enableRedistributableFirmware= true;
+ #krebs.nixpkgs.allowUnfreePredicate = pkg:
+ # hasPrefix "nvidia-x11-" pkg.name ||
+ # hasPrefix "nvidia-persistenced-" pkg.name ||
+ # hasPrefix "nvidia-settings-" pkg.name;
+ }
];
boot.extraModprobeConfig = ''
@@ -15,6 +27,7 @@
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
+ hardware.opengl.driSupport32Bit = true;
hardware.opengl.extraPackages = [ pkgs.vaapiIntel ];
networking.wireless.enable = true;
@@ -41,4 +54,8 @@
echo auto > $i/power/control # defaults to 'on'
done)
'';
+
+ services.xserver = {
+ videoDriver = "intel";
+ };
}