summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack/nix-cacher.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-06-01 12:49:36 +0200
committerlassulus <lass@lassul.us>2017-06-01 12:49:36 +0200
commite50bc4f3eb3dac13bba4ae6158e839a52455c3c3 (patch)
treeb3c1fc1f3e00312e92e4ab747c31839db665eebd /shared/2configs/shack/nix-cacher.nix
parent73b073c3fe037f31e05828a1071c9b4b19f7a2ff (diff)
parent9e04d0132133840fba14aca194f18925e3f353d5 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'shared/2configs/shack/nix-cacher.nix')
-rw-r--r--shared/2configs/shack/nix-cacher.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shared/2configs/shack/nix-cacher.nix b/shared/2configs/shack/nix-cacher.nix
new file mode 100644
index 000000000..4fcbf3a4e
--- /dev/null
+++ b/shared/2configs/shack/nix-cacher.nix
@@ -0,0 +1,28 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+let
+ cfg = config.krebs.apt-cacher-ng;
+in
+{
+ krebs.apt-cacher-ng = {
+ enable = true;
+ port = 3142;
+ bindAddress = "localhost";
+ cacheExpiration = 30;
+ };
+
+ services.nginx = {
+ enable = mkDefault true;
+ virtualHosts.shack-nix-cacher = {
+ serverAliases = [
+ "acng.shack"
+ ];
+ locations."/".extraConfig = ''
+ proxy_set_header Host $host;
+ proxy_set_header X-Real-IP $remote_addr;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_pass http://localhost:${toString cfg.port}/;
+ '';
+ };
+ };
+}