summaryrefslogtreecommitdiffstats
path: root/shared/2configs/repo-sync.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-02-17 15:02:45 +0100
committerlassulus <lass@aidsballs.de>2016-02-17 15:02:45 +0100
commitf48e90915f9c1477a7068050e06a8686ceb03427 (patch)
tree7f3cb5987b2f962fa7f93ffab0c8d47267f70764 /shared/2configs/repo-sync.nix
parent5c8606e6f6b9337d6f9c1241bf0af84af9db0bdf (diff)
parentd923ede6e33c57901039da59d50c45938228fd7a (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'shared/2configs/repo-sync.nix')
-rw-r--r--shared/2configs/repo-sync.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shared/2configs/repo-sync.nix b/shared/2configs/repo-sync.nix
new file mode 100644
index 000000000..b23cb1675
--- /dev/null
+++ b/shared/2configs/repo-sync.nix
@@ -0,0 +1,28 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ krebs.repo-sync = let
+ # TODO addMirrorURL function
+ mirror = "git@wolf:stockholm-mirror";
+ in {
+ enable = true;
+ config = {
+ makefu = {
+ origin.url = http://cgit.gum/stockholm ;
+ mirror.url = mirror;
+ };
+ tv = {
+ origin.url = http://cgit.cd/stockholm ;
+ mirror.url = mirror;
+ };
+ lassulus = {
+ origin.url = http://cgit.cloudkrebs/stockholm ;
+ mirror.url = mirror;
+ };
+ "@latest" = {
+ mirror.url = mirror;
+ };
+ };
+ };
+}