summaryrefslogtreecommitdiffstats
path: root/shared/1systems/test-arch/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-13 00:37:54 +0200
committertv <tv@krebsco.de>2017-07-13 00:37:54 +0200
commitbc6c6a3164d31141f39333914c1b15ff261e7859 (patch)
tree8bff8dd19f1d9f9fcc2b78b7c8d3fb81a332aab4 /shared/1systems/test-arch/config.nix
parent4da01794605291bdb7bd9fa9dc7109764f4faf58 (diff)
parent7212de210bb7fc751ffade00d6b1b08f195ddf47 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'shared/1systems/test-arch/config.nix')
-rw-r--r--shared/1systems/test-arch/config.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/shared/1systems/test-arch/config.nix b/shared/1systems/test-arch/config.nix
new file mode 100644
index 000000000..453483d48
--- /dev/null
+++ b/shared/1systems/test-arch/config.nix
@@ -0,0 +1,32 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ <stockholm/shared>
+ {
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "vmw_pvscsi"
+ ];
+
+ fileSystems."/" = {
+ device = "/dev/sda1";
+ };
+ }
+ {
+ networking.dhcpcd.allowInterfaces = [
+ "enp*"
+ ];
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.test-arch;
+}