summaryrefslogtreecommitdiffstats
path: root/nin/krops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-11-05 18:20:42 +0100
committermakefu <github@syntax-fehler.de>2018-11-05 18:20:42 +0100
commit254e9e62b95951cecadd2b4800c03ef96f95b3c0 (patch)
tree6892ca816d01eb712b80af9dbd79cc6690f21752 /nin/krops.nix
parent8b57f04ff84b53742ef6a8a9677560745075ffb1 (diff)
parent100ca928ad483471d61b36bd9e977e34441d404b (diff)
Merge remote-tracking branch 'lassul.us/master'
Diffstat (limited to 'nin/krops.nix')
-rw-r--r--nin/krops.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/nin/krops.nix b/nin/krops.nix
new file mode 100644
index 000000000..fef8cc38b
--- /dev/null
+++ b/nin/krops.nix
@@ -0,0 +1,36 @@
+{ name }: let
+ inherit (import ../krebs/krops.nix { inherit name; })
+ krebs-source
+ lib
+ pkgs
+ ;
+
+ source = { test }: lib.evalSource [
+ krebs-source
+ {
+ nixos-config.symlink = "stockholm/nin/1systems/${name}/config.nix";
+ secrets = if test then {
+ file = toString ./0tests/dummysecrets;
+ } else {
+ pass = {
+ dir = "${lib.getEnv "HOME"}/.password-store";
+ name = "hosts/${name}";
+ };
+ };
+ }
+ ];
+
+in {
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
+ deploy = pkgs.krops.writeDeploy "${name}-deploy" {
+ source = source { test = false; };
+ target = "root@${name}/var/src";
+ };
+
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)
+ test = { target }: pkgs.krops.writeTest "${name}-test" {
+ force = true;
+ inherit target;
+ source = source { test = true; };
+ };
+}