summaryrefslogtreecommitdiffstats
path: root/nin/krops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-10-07 23:12:16 +0200
committermakefu <github@syntax-fehler.de>2018-10-07 23:12:16 +0200
commit91023a11ebae6794caaecc882892da7f90deea28 (patch)
tree5bfd29cf49b1248cff80c4e001b0bf78b972ff26 /nin/krops.nix
parent9104af869e8c8ce299fc2ddbf7f2631bbbf48b1e (diff)
parent6b08d5aa46adc80d8a1ab4ed1d3e320c61a19f01 (diff)
Merge remote-tracking branch 'lass/18.09' into 18.09
Diffstat (limited to 'nin/krops.nix')
-rw-r--r--nin/krops.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/nin/krops.nix b/nin/krops.nix
deleted file mode 100644
index d0074840a..000000000
--- a/nin/krops.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ name }: let
- inherit (import ../krebs/krops.nix { inherit name; })
- krebs-source
- lib
- pkgs
- ;
-
- source = { test }: lib.evalSource [
- krebs-source
- {
- nixos-config.symlink = "stockholm/nin/1systems/${name}/config.nix";
- secrets = if test then {
- file = toString ./0tests/dummysecrets;
- } else {
- pass = {
- dir = "${lib.getEnv "HOME"}/.password-store";
- name = "hosts/${name}";
- };
- };
- }
- ];
-
-in {
- # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
- deploy = pkgs.krops.writeDeploy "${name}-deploy" {
- source = source { test = false; };
- target = "root@${name}/var/src";
- };
-
- # usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)
- test = { target }: pkgs.krops.writeTest "${name}-test" {
- inherit target;
- source = source { test = true; };
- };
-}