summaryrefslogtreecommitdiffstats
path: root/nin/2configs/ableton.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-10-09 21:09:42 +0200
committernin <nin@c-base.org>2018-10-09 21:09:42 +0200
commit239a31abd02a84f04eb062b9ad0348ec424a58c9 (patch)
tree7bde5b4ca54eaa11fa8da2b9bbfadfda326eb598 /nin/2configs/ableton.nix
parent685dd36289f1db0d4c430fb9af89b68310007820 (diff)
Revert "remove nin"
This reverts commit 62314e64c259bc6bae39e2bd29ecec2c5e5ea262.
Diffstat (limited to 'nin/2configs/ableton.nix')
-rw-r--r--nin/2configs/ableton.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nin/2configs/ableton.nix b/nin/2configs/ableton.nix
new file mode 100644
index 000000000..343a9089d
--- /dev/null
+++ b/nin/2configs/ableton.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.nin;
+in {
+ users.users= {
+ ableton = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ pkgs.wine
+ pkgs.winetricks
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(ableton) NOPASSWD: ALL
+ '';
+}