summaryrefslogtreecommitdiffstats
path: root/nin/2configs/ableton.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-03-07 01:49:57 +0100
committermakefu <github@syntax-fehler.de>2018-03-07 01:49:57 +0100
commit6b647a237a5f4db23b7eff70f305be7106da7711 (patch)
tree3542eabb416599e0d2dea8a2f2358f27f4b911e2 /nin/2configs/ableton.nix
parent194e7011d42ed75c76dc7a7efea450ba6497d2f1 (diff)
parent02f67eed443ba552d775d1a0ab7860d439f7552b (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'nin/2configs/ableton.nix')
-rw-r--r--nin/2configs/ableton.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nin/2configs/ableton.nix b/nin/2configs/ableton.nix
new file mode 100644
index 000000000..343a9089d
--- /dev/null
+++ b/nin/2configs/ableton.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.nin;
+in {
+ users.users= {
+ ableton = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ pkgs.wine
+ pkgs.winetricks
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(ableton) NOPASSWD: ALL
+ '';
+}