summaryrefslogtreecommitdiffstats
path: root/modules/mors/repos.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-14 19:22:37 +0200
committertv <tv@shackspace.de>2015-06-14 19:22:37 +0200
commitbff3b50dddb1bb37831d9f17ca25ccab7f7476fe (patch)
tree6a36b91b0ed33ba90b4da32d1fa995789f923a8d /modules/mors/repos.nix
parent78c3c09f1579d1f8132d95d260e9ed8789d3dfc5 (diff)
parentafa7f0b98d89c9746c204e4ee0dd79e7ae4eb23f (diff)
Merge remote-tracking branch 'mors/master' into mors-staging
Diffstat (limited to 'modules/mors/repos.nix')
-rw-r--r--modules/mors/repos.nix78
1 files changed, 78 insertions, 0 deletions
diff --git a/modules/mors/repos.nix b/modules/mors/repos.nix
new file mode 100644
index 000000000..e31ba9481
--- /dev/null
+++ b/modules/mors/repos.nix
@@ -0,0 +1,78 @@
+{ ... }:
+
+{
+ imports = [
+ ../lass/gitolite-base.nix
+ ../common/krebs-keys.nix
+ ../common/krebs-repos.nix
+ ];
+
+ services.gitolite = {
+ repos = {
+
+ config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ pass = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ load-env = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ emse-hsdb = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ brain = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ #hooks.post-receive = irc-announce;
+ };
+
+ painload = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ services = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ xmonad-config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ };
+ };
+}