summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/switch-launcher/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-11-10 19:42:46 +0100
committerlassulus <lass@blue.r>2018-11-10 19:42:46 +0100
commiteff97662c02f385b1740929639817fc5b8318f07 (patch)
treef11710101eed0dcc8d75304939f06e819339d9f0 /makefu/5pkgs/switch-launcher/default.nix
parent0028e3dde3dcb8e5e9394f7d230c7224b6177b79 (diff)
parent254e9e62b95951cecadd2b4800c03ef96f95b3c0 (diff)
Merge remote-tracking branch 'nextgum/master'
Diffstat (limited to 'makefu/5pkgs/switch-launcher/default.nix')
-rw-r--r--makefu/5pkgs/switch-launcher/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefu/5pkgs/switch-launcher/default.nix b/makefu/5pkgs/switch-launcher/default.nix
new file mode 100644
index 000000000..cc7905a31
--- /dev/null
+++ b/makefu/5pkgs/switch-launcher/default.nix
@@ -0,0 +1,24 @@
+{ lib, pkgs, python3Packages, ... }:
+
+with python3Packages; buildPythonPackage rec {
+ name = "nodemcu-uploader-${version}";
+ version = "0.1.0";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "ksmit799";
+ repo = "switch-launcher";
+ rev = version;
+ sha256 = "0j24dwiqqjiks59s8gilnplsls130mp1jssg2rpjrvj0jg0w52zz";
+ };
+
+
+ propagatedBuildInputs = [
+ pyusb
+ ];
+
+ meta = {
+ homepage = https://github.com/ksmit799/switch-launcher;
+ description = "Desktop switch payload launcher based on a modified reswitched injector";
+ license = lib.licenses.bsd3;
+ };
+}