summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/pfsshell/default.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-02-11 16:11:08 +0100
committernin <nin@c-base.org>2018-02-11 16:11:08 +0100
commitf20bf1a7ba146b3ffe3f2e470614d12885cbce61 (patch)
tree092a5e5864814a42b854937a06b8d1ecb8a74402 /makefu/5pkgs/pfsshell/default.nix
parent6849d7aa4810d5f1f2ec55d852d21812dd1b8002 (diff)
parentdbd48fdbf91672dc96992ee0b55ad1da226d4199 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'makefu/5pkgs/pfsshell/default.nix')
-rw-r--r--makefu/5pkgs/pfsshell/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/pfsshell/default.nix b/makefu/5pkgs/pfsshell/default.nix
new file mode 100644
index 000000000..fc6b37069
--- /dev/null
+++ b/makefu/5pkgs/pfsshell/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, lib, pkgs, fetchurl,fetchFromGitHub, upx, wine }:
+stdenv.mkDerivation rec {
+ pname = "pfsshell";
+ version = "64f8c2";
+ name = "${pname}-${version}";
+
+ src = fetchFromGitHub {
+ owner = "makefu";
+ repo = "pfsshell";
+ rev = version;
+ sha256 = "01lbqf8s91p8id58xa16fp555i03vfycqvhv7qzpnrjy6yvp9dm8";
+ };
+
+ buildInputs = [ ];
+
+ makeFlags = [ ];
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp pfsshell $out/bin
+ '';
+
+ meta = {
+ homepage = https://github.com/uyjulian/pfsshell ;
+ description = "browse and transfer files to/from PFS filesystems";
+ };
+}