summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/mcomix/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-08-16 12:03:32 +0200
committermakefu <github@syntax-fehler.de>2017-08-16 12:03:32 +0200
commitbacdb91d8d5a856d735ff8c52ecb0010511027b7 (patch)
tree8d1a34871102c685fdf0338a767aedd359397fb2 /makefu/5pkgs/mcomix/default.nix
parent60be2e12f968ba0097289f0a2ce47d870e9e4c2d (diff)
ma 5pkgs: cleanup
Diffstat (limited to 'makefu/5pkgs/mcomix/default.nix')
-rw-r--r--makefu/5pkgs/mcomix/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/5pkgs/mcomix/default.nix b/makefu/5pkgs/mcomix/default.nix
new file mode 100644
index 000000000..a12e2e821
--- /dev/null
+++ b/makefu/5pkgs/mcomix/default.nix
@@ -0,0 +1,20 @@
+{ pkgs, lib ,python2Packages, fetchurl, gtk3}:
+python2Packages.buildPythonPackage rec {
+ name = "mcomix-${version}";
+ version = "1.2.1";
+
+ src = fetchurl {
+ url = "mirror://sourceforge/mcomix/${name}.tar.bz2";
+ sha256 = "0fzsf9pklhfs1rzwzj64c0v30b74nk94p93h371rpg45qnfiahvy";
+ };
+
+ propagatedBuildInputs = with python2Packages;
+ [ python2Packages.pygtk gtk3 python2Packages.pillow ];
+
+ meta = {
+ homepage = https://github.com/pyload/pyload;
+ description = "Free and Open Source download manager written in Python";
+ license = lib.licenses.gpl3;
+ maintainers = with lib.maintainers; [ makefu ];
+ };
+}