summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/hdl-dump
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-01-11 23:03:10 +0100
committernin <nin@c-base.org>2018-01-11 23:03:10 +0100
commit80c2e23ec028bfda5c0bad0e3269648d34d298b0 (patch)
tree0b1a0b2312ee8afc874639b5d2ee52fc410403fe /makefu/5pkgs/hdl-dump
parent64b06a2a0c09f5e57f65bcbf1494c856b58666c3 (diff)
parent279ce3bbbc562d53ba4696c90025671be32b5e0e (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'makefu/5pkgs/hdl-dump')
-rw-r--r--makefu/5pkgs/hdl-dump/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/makefu/5pkgs/hdl-dump/default.nix b/makefu/5pkgs/hdl-dump/default.nix
new file mode 100644
index 000000000..bd454223a
--- /dev/null
+++ b/makefu/5pkgs/hdl-dump/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, lib, pkgs, fetchurl,fetchFromGitHub, upx, wine }:
+stdenv.mkDerivation rec {
+ pname = "hdl-dump";
+ version = "75df8d7";
+ name = "${pname}-${version}";
+
+ src = fetchFromGitHub {
+ owner = "AKuHAK";
+ repo = "hdl-dump";
+ rev = version;
+ sha256 = "10jjr6p5yn0c182x17m7q68jmf8gizcny7wjxw7z5yh0fv5s48z4";
+ };
+
+ buildInputs = [ upx wine ];
+
+ makeFlags = [ "RELEASE=yes" ];
+
+ # uses wine, currently broken
+ #postBuild = ''
+ # make -C gui
+ #'';
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp hdl_dump $out/bin
+ '';
+
+ meta = {
+ homepage = https://github.com/AKuHAK/hdl-dump ;
+ description = "copy isos to psx hdd";
+ license = lib.licenses.gpl2;
+ };
+}