summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/bin2iso/default.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-01-11 23:03:10 +0100
committernin <nin@c-base.org>2018-01-11 23:03:10 +0100
commit80c2e23ec028bfda5c0bad0e3269648d34d298b0 (patch)
tree0b1a0b2312ee8afc874639b5d2ee52fc410403fe /makefu/5pkgs/bin2iso/default.nix
parent64b06a2a0c09f5e57f65bcbf1494c856b58666c3 (diff)
parent279ce3bbbc562d53ba4696c90025671be32b5e0e (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'makefu/5pkgs/bin2iso/default.nix')
-rw-r--r--makefu/5pkgs/bin2iso/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/makefu/5pkgs/bin2iso/default.nix b/makefu/5pkgs/bin2iso/default.nix
new file mode 100644
index 000000000..31d05fab3
--- /dev/null
+++ b/makefu/5pkgs/bin2iso/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, lib, pkgs, fetchurl }:
+stdenv.mkDerivation rec {
+ pname = "bin2iso";
+ version = "1.9b";
+ _dlver = builtins.replaceStrings ["."] [""] version;
+ name = "${pname}-${version}";
+
+ src = fetchurl {
+ url = "http://users.eastlink.ca/~doiron/${pname}/linux/${pname}${_dlver}_linux.c";
+ sha256 = "0gg4hbzlm83nnbccy79dnxbwpn7lxl3fb87ka36mlclikvknm2hy";
+ };
+
+ unpackPhase = "true";
+
+ buildPhase =''
+ gcc -Wall -o $pname $src
+ '';
+
+ installPhase = ''
+ install -Dm755 $pname $out/bin/$pname
+ '';
+
+ meta = {
+ homepage = http://users.eastlink.ca/~doiron/bin2iso/ ;
+ description = "converts bin+cue to iso";
+ license = lib.licenses.gpl3;
+ };
+}