summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/ampel
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-02-11 16:11:08 +0100
committernin <nin@c-base.org>2018-02-11 16:11:08 +0100
commitf20bf1a7ba146b3ffe3f2e470614d12885cbce61 (patch)
tree092a5e5864814a42b854937a06b8d1ecb8a74402 /makefu/5pkgs/ampel
parent6849d7aa4810d5f1f2ec55d852d21812dd1b8002 (diff)
parentdbd48fdbf91672dc96992ee0b55ad1da226d4199 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'makefu/5pkgs/ampel')
-rw-r--r--makefu/5pkgs/ampel/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/ampel/default.nix b/makefu/5pkgs/ampel/default.nix
new file mode 100644
index 000000000..86518b9b8
--- /dev/null
+++ b/makefu/5pkgs/ampel/default.nix
@@ -0,0 +1,27 @@
+{ lib, pkgs, fetchFromGitHub, ... }:
+
+with pkgs.python3Packages;buildPythonPackage rec {
+ name = "ampel-${version}";
+ version = "0.2";
+
+ propagatedBuildInputs = [
+ docopt
+ paho-mqtt
+ requests
+ pytz
+ influxdb
+ httplib2
+ google_api_python_client
+ ];
+
+ src = pkgs.fetchgit {
+ url = "http://cgit.euer.krebsco.de/ampel";
+ rev = "d8a0250";
+ sha256 = "0n36lc17ca5db6pl6dswdqd5w9f881rfqck9yc4w33a5qpsxj85f";
+ };
+ meta = {
+ homepage = http://cgit.euer.krebsco.de/ampel;
+ description = "change colors of rgb cubes";
+ license = lib.licenses.asl20;
+ };
+}