summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/airdcpp-webclient/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-09-24 10:19:34 +0200
committerlassulus <lass@blue.r>2018-09-24 10:19:34 +0200
commit260b757feebf710daeb4d8964297dff2ed794278 (patch)
treebe58e53ad90f14928ff888ab10d0a501df78c744 /makefu/5pkgs/airdcpp-webclient/default.nix
parentf473c1f7893abb4d7f299d5cf7d0f382086cba9e (diff)
parent1996b597480ab45bbd15c0d7095921ced7a9e9ab (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/5pkgs/airdcpp-webclient/default.nix')
-rw-r--r--makefu/5pkgs/airdcpp-webclient/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/airdcpp-webclient/default.nix b/makefu/5pkgs/airdcpp-webclient/default.nix
new file mode 100644
index 000000000..361a7da65
--- /dev/null
+++ b/makefu/5pkgs/airdcpp-webclient/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl
+}:
+stdenv.mkDerivation rec {
+ name = "airdcpp-webclient-${version}";
+ version = "2.3.0";
+
+ src = fetchurl {
+ url = http://web-builds.airdcpp.net/stable/airdcpp_2.3.0_webui-2.3.0_64-bit_portable.tar.gz;
+ sha256 = "0yvcl0nc70fghc7vfsgvbpryi5q97arld8adql4way4qa0mdnyv1";
+ };
+
+ phases = [ "unpackPhase" "installPhase" ];
+ installPhase = ''
+ mkdir -p $out/{share,bin}
+ cp -r * $out/share
+ ln -s $out/share/airdcppd $out/bin/
+ '';
+
+ meta = with stdenv.lib; {
+ # to start it: airdcpp -p=<pid-file> -c=<config-store-path (must be writeable)> --configure
+ description = "dcpp client (statically precompiled)";
+ homepage = http://fixme;
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ makefu ];
+ platforms = with platforms; linux;
+ };
+}