summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/torrent.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-12-31 03:02:48 +0100
committerlassulus <lassulus@lassul.us>2017-12-31 03:02:48 +0100
commitf2fe825333854ba8f07a95200c67194aeae0fb5f (patch)
tree3fb255c276a0d0bc305f619a944b8204a64bc702 /makefu/2configs/torrent.nix
parentd5a69ce257d44c804d1edb679e5667eae6a71853 (diff)
parent181bd547f370848df1a49f886355e6fe8853c02f (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/torrent.nix')
-rw-r--r--makefu/2configs/torrent.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/makefu/2configs/torrent.nix b/makefu/2configs/torrent.nix
index d063ad3e3..a076479c2 100644
--- a/makefu/2configs/torrent.nix
+++ b/makefu/2configs/torrent.nix
@@ -8,13 +8,13 @@ let
peer-port = 51412;
web-port = 8112;
daemon-port = 58846;
- dl-dir = config.makefu.dl-dir;
+ torrent-dir = config.makefu.dl-dir;
in {
users.users = {
download = {
name = "download";
- home = dl-dir;
+ home = torrent-dir;
uid = mkDefault (genid "download");
createHome = true;
useDefaultShell = true;
@@ -26,9 +26,9 @@ in {
# todo: race condition, do this after download user has been created
system.activationScripts."download-dir-chmod" = ''
for i in finished watch torrents; do
- mkdir -p "${dl-dir}/$i"
- chown download:download "${dl-dir}/$i"
- chmod 770 "${dl-dir}/$i"
+ mkdir -p "${torrent-dir}/$i"
+ chown download:download "${torrent-dir}/$i"
+ chmod 770 "${torrent-dir}/$i"
done
'';
@@ -54,9 +54,8 @@ in {
rutorrent.enable = true;
enableXMLRPC = true;
listenPort = peer-port;
- downloadDir = dl-dir + "/finished";
+ workDir = torrent-dir;
# dump old torrents into watch folder to have them re-added
- watchDir = dl-dir +"/watch";
};
networking.firewall.extraCommands = ''