summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/rtorrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-23 13:09:16 +0200
committermakefu <github@syntax-fehler.de>2016-08-23 13:09:16 +0200
commitd73d55209619c996e6e71dbc282fe188f11de805 (patch)
tree56774305dee9eba4a58ad707231577d046251165 /makefu/2configs/rtorrent.nix
parent7761a15e57fe63112de01b232b7d67c3fe16df72 (diff)
m rtorrent: split web rpc and rutorrent functionality
Diffstat (limited to 'makefu/2configs/rtorrent.nix')
-rw-r--r--makefu/2configs/rtorrent.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/makefu/2configs/rtorrent.nix b/makefu/2configs/rtorrent.nix
index d024ded97..9e2990cab 100644
--- a/makefu/2configs/rtorrent.nix
+++ b/makefu/2configs/rtorrent.nix
@@ -2,11 +2,17 @@ _:
let
listenPort = 60123;
xml-port = 5000;
+ authfile = <torrent-secrets/authfile>;
in {
makefu.rtorrent = {
enable = true;
- web.enable = true;
- xmlrpc = "localhost:${toString xml-port}";
+ web = {
+ enable = true;
+ enableAuth = true;
+ inherit authfile;
+ };
+ rutorrent.enable = true;
+ enableXMLRPC = true;
logLevel = "debug";
inherit listenPort;
};