summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/tp-x230.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-10-27 14:59:47 +0200
committerlassulus <lass@aidsballs.de>2016-10-27 14:59:47 +0200
commit98659a68c7c40bee92e851afcf5a9bebeb3e2a06 (patch)
treeef9ed3bce885ad39eccc35a79b069bf269ae939a /makefu/2configs/hw/tp-x230.nix
parent3306e32498fc0c784ec6975a7911bf84d5ff1091 (diff)
parent2e22fa7234c95cccb1680fb47954f339e6e0b326 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/hw/tp-x230.nix')
-rw-r--r--makefu/2configs/hw/tp-x230.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/makefu/2configs/hw/tp-x230.nix b/makefu/2configs/hw/tp-x230.nix
new file mode 100644
index 000000000..99563a771
--- /dev/null
+++ b/makefu/2configs/hw/tp-x230.nix
@@ -0,0 +1,44 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+{
+
+ imports = [ ./tp-x2x0.nix ];
+ boot = {
+ # tp-smapi is not supported bt x230 anymore
+ kernelModules = [
+ "kvm-intel"
+ "thinkpad_ec"
+ # "acpi_call"
+ # "thinkpad_acpi"
+ # "tpm-rng"
+ ];
+ extraModulePackages = [
+ # config.boot.kernelPackages.acpi_call
+ ];
+ };
+ services.acpid.enable = true;
+ hardware.opengl.extraPackages = [ pkgs.vaapiIntel pkgs.vaapiVdpau ];
+ services.xserver = {
+ videoDriver = "intel";
+ deviceSection = ''
+ Option "AccelMethod" "sna"
+ '';
+ };
+ # no entropy source working
+ # security.rngd.enable = true;
+
+ services.xserver.displayManager.sessionCommands =''
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 8 1
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 8 2
+ xinput set-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Axes" 6 7 4 5
+ # xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Timeout" 8 200
+ '';
+
+ # enable HDMI output switching with pulseaudio
+ hardware.pulseaudio.configFile = pkgs.writeText "pulse-default-pa" ''
+ ${builtins.readFile "${config.hardware.pulseaudio.package.out}/etc/pulse/default.pa"}
+ load-module module-alsa-sink device=hw:0,3 sink_properties=device.description="HDMIOutput" sink_name="HDMI"
+ '';
+
+}