summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/bluetooth.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-06-13 21:25:24 +0200
committerlassulus <lass@blue.r>2018-06-13 21:25:24 +0200
commit006a3174eccecfee96e7b4fb9c818043a0334535 (patch)
tree516b9d74a3ca3d5ad9113aa84a89756ed7b85a23 /makefu/2configs/hw/bluetooth.nix
parent386d9849e8a4a1aaa16c7055049b2e925916653e (diff)
parent3c704cf61e2dc48629af6e331c21d9c5be5d277b (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/hw/bluetooth.nix')
-rw-r--r--makefu/2configs/hw/bluetooth.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/makefu/2configs/hw/bluetooth.nix b/makefu/2configs/hw/bluetooth.nix
new file mode 100644
index 000000000..85c3190ff
--- /dev/null
+++ b/makefu/2configs/hw/bluetooth.nix
@@ -0,0 +1,39 @@
+{ pkgs, ... }:
+{ # bluetooth+pulse config
+# for blueman-applet
+ users.users.makefu.packages = [
+ pkgs.blueman
+ ];
+ hardware.pulseaudio = {
+ enable = true;
+ package = pkgs.pulseaudioFull;
+# systemWide = true;
+ support32Bit = true;
+ configFile = pkgs.writeText "default.pa" ''
+ load-module module-udev-detect
+ load-module module-bluetooth-policy
+ load-module module-bluetooth-discover
+ load-module module-native-protocol-unix
+ load-module module-always-sink
+ load-module module-console-kit
+ load-module module-systemd-login
+ load-module module-intended-roles
+ load-module module-position-event-sounds
+ load-module module-filter-heuristics
+ load-module module-filter-apply
+ load-module module-switch-on-connect
+ load-module module-switch-on-port-available
+ '';
+ };
+
+# presumably a2dp Sink
+# Enable profile:
+## pacmd set-card-profile "$(pactl list cards short | egrep -o bluez_card[[:alnum:]._]+)" a2dp_sink
+ hardware.bluetooth.extraConfig = '';
+ [general]
+ Enable=Source,Sink,Media,Socket
+ '';
+
+# connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
+ hardware.bluetooth.enable = true;
+}