summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/wiki-irc.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-05-24 10:53:08 +0200
committermakefu <github@syntax-fehler.de>2017-05-24 10:53:08 +0200
commit54ca947fe1f918d1b62d479df308637d60a3143b (patch)
tree661709afcb28d9fb0811ab5cea13d2c4780847b4 /makefu/2configs/deployment/wiki-irc.nix
parent00f5855223ecda48979314eeb550b5885e418a00 (diff)
m 2 wiki-irc-bot: move to subdir, add patch
Diffstat (limited to 'makefu/2configs/deployment/wiki-irc.nix')
-rw-r--r--makefu/2configs/deployment/wiki-irc.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/makefu/2configs/deployment/wiki-irc.nix b/makefu/2configs/deployment/wiki-irc.nix
deleted file mode 100644
index dc7c8afe8..000000000
--- a/makefu/2configs/deployment/wiki-irc.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{ pkgs, lib, ... }:
-
-with lib;
-let
- port = 18872;
-in {
- services.logstash = {
- enable = true;
- inputConfig = ''
- http {
- port => ${toString port}
- host => "127.0.0.1"
- }
- '';
- filterConfig = ''
- if ([pages]) {
- ruby {
- code => '
- require "net/http"
- require "net/https"
- http = Net::HTTP.new("git.io", 443)
- http.use_ssl = true
- lines = []
- event["pages"].each {|p|
- url = "#{p["html_url"]}/_compare/#{p["sha"]}"
- short_url = begin
- request = Net::HTTP::Post.new "/"
- request.set_form_data ({"url" => url })
- response = http.request(request)
- response["location"]
- end
- lines << "\"#{p["title"]}\" #{p["action"]} by #{event["sender"]["login"]} #{short_url}"
- }
- event["output"] = lines.join("\n")
- '
- }
- }
- '';
- outputConfig = ''
- file { path => "/tmp/logs.json" codec => "json_lines" }
- if [output] {
- irc {
- channels => [ "#nixos" , "#krebs" ]
- host => "irc.freenode.net"
- nick => "nixos-users-wiki"
- format => "%{output}"
- }
- }
- '';
- plugins = [ ];
- };
-
- services.nginx = {
- enable = lib.mkDefault true;
- virtualHosts."ghook.krebsco.de" = {
- locations."/".proxyPass = "http://localhost:${toString port}/";
- enableSSL = true;
- enableACME = true;
- forceSSL = true;
- };
- };
-}