summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wbob.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-07-22 13:22:13 +0200
committertv <tv@krebsco.de>2016-07-22 13:22:13 +0200
commit45c62ec4d3ec61ba593657676f5a09d47622564e (patch)
tree7937fbefaddc5e0168e44ab1d6e355c42192d7e8 /makefu/1systems/wbob.nix
parent8b58e6e6e25e38586f3cc8879aa0444d4fdf6f0d (diff)
parent0bd78c3b0de0fa79322e9031f45dcc62abd094d1 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/1systems/wbob.nix')
-rw-r--r--makefu/1systems/wbob.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/makefu/1systems/wbob.nix b/makefu/1systems/wbob.nix
index 45b935af0..e8e0b091f 100644
--- a/makefu/1systems/wbob.nix
+++ b/makefu/1systems/wbob.nix
@@ -1,5 +1,7 @@
{ config, pkgs, ... }:
-{
+let rootdisk = "/dev/disk/by-id/ata-TS256GMTS800_C613840115";
+in {
+
makefu.awesome = {
modkey = "Mod1";
#TODO: integrate kiosk config into full config by templating the autostart
@@ -9,19 +11,19 @@
[ # Include the results of the hardware scan.
../.
../2configs/main-laptop.nix
+ ../2configs/virtualization.nix
+ ../2configs/tinc/retiolum.nix
];
krebs = {
enable = true;
- retiolum.enable = true;
build.host = config.krebs.hosts.wbob;
};
networking.firewall.allowedUDPPorts = [ 1655 ];
- networking.firewall.allowedTCPPorts = [ 1655 ];
+ networking.firewall.allowedTCPPorts = [ 1655 49152 ];
services.tinc.networks.siem = {
name = "display";
extraConfig = ''
ConnectTo = sjump
- Port = 1655
'';
};
@@ -35,12 +37,12 @@
# nuc hardware
- boot.loader.grub.device = "/dev/sda";
+ boot.loader.grub.device = rootdisk;
hardware.cpu.intel.updateMicrocode = true;
boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
boot.kernelModules = [ "kvm-intel" ];
fileSystems."/" = {
- device = "/dev/sda1";
+ device = rootdisk + "-part1";
fsType = "ext4";
};