summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/vbob.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-05-02 17:40:59 +0200
committermakefu <github@syntax-fehler.de>2016-05-02 17:40:59 +0200
commit89ad52088dffd21a229e912e8bd473abdae53f73 (patch)
tree1ec97b6b8266d51bfb9205293d1926229fb96c39 /makefu/1systems/vbob.nix
parentc9602f5d1ae52333d17c2cf50f4cd1a0d8dcdb7b (diff)
parent64aa4f6912fb7425d8063e5d143f59c43fb31b8f (diff)
Merge branch 'master' of gum.krebsco.de:stockholm
Diffstat (limited to 'makefu/1systems/vbob.nix')
-rw-r--r--makefu/1systems/vbob.nix19
1 files changed, 15 insertions, 4 deletions
diff --git a/makefu/1systems/vbob.nix b/makefu/1systems/vbob.nix
index 36ae88d22..8b71b1393 100644
--- a/makefu/1systems/vbob.nix
+++ b/makefu/1systems/vbob.nix
@@ -17,6 +17,10 @@
device ="/dev/disk/by-label/nixstore";
fsType = "ext4";
};
+ fileSystems."/var/lib/docker" = {
+ device ="/dev/disk/by-label/nix-docker";
+ fsType = "ext4";
+ };
#makefu.buildbot.master.enable = true;
# allow vbob to deploy self
users.extraUsers = {
@@ -26,11 +30,14 @@
};
environment.systemPackages = with pkgs;[
fortclientsslvpn
- buildbot
- buildbot-slave
get
logstash
+ docker
+ devpi-web
+ devpi-client
];
+ # virtualisation.docker.enable = true;
+
networking.firewall.allowedTCPPorts = [
25
@@ -40,13 +47,17 @@
krebs.retiolum = {
enable = true;
- #extraConfig = "Proxy = http global.proxy.alcatel-lucent.com 8000";
connectTo = [
+ "omo"
"gum"
];
};
- #networking.proxy.default = "http://global.proxy.alcatel-lucent.com:8000";
+ networking.extraHosts = ''
+ 172.17.20.190 gitlab
+ 172.17.62.27 svbittool01 tool
+ '';
+
fileSystems."/media/share" = {
fsType = "vboxsf";
device = "share";