summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-01-09 19:06:50 +0100
committertv <tv@krebsco.de>2018-01-09 19:06:50 +0100
commit8ff5c5e992ebafeca5edb2b22a0ab700edc715a5 (patch)
treee141f28bca4e5494669282d41c1c8dbbc96b4ce8 /makefu/1systems/omo/config.nix
parentfb0bbec70ae1a0dd4fdc3c9bc9ed47f2a8573fd9 (diff)
parent5ef3a2c6caa2f018c2adf795de992e0487dd2413 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/1systems/omo/config.nix')
-rw-r--r--makefu/1systems/omo/config.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/makefu/1systems/omo/config.nix b/makefu/1systems/omo/config.nix
index aaecebadc..ce3ffbcf3 100644
--- a/makefu/1systems/omo/config.nix
+++ b/makefu/1systems/omo/config.nix
@@ -143,7 +143,10 @@ in {
];
fileSystems = let
cryptMount = name:
- { "/media/${name}" = { device = "/dev/mapper/${name}"; fsType = "xfs"; };};
+ { "/media/${name}" = {
+ device = "/dev/mapper/${name}"; fsType = "xfs";
+ options = [ "nofail" ];
+ };};
in cryptMount "crypt0"
// cryptMount "crypt1"
// cryptMount "crypt2"