summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo/config.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-01-11 23:03:10 +0100
committernin <nin@c-base.org>2018-01-11 23:03:10 +0100
commit80c2e23ec028bfda5c0bad0e3269648d34d298b0 (patch)
tree0b1a0b2312ee8afc874639b5d2ee52fc410403fe /makefu/1systems/omo/config.nix
parent64b06a2a0c09f5e57f65bcbf1494c856b58666c3 (diff)
parent279ce3bbbc562d53ba4696c90025671be32b5e0e (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'makefu/1systems/omo/config.nix')
-rw-r--r--makefu/1systems/omo/config.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/makefu/1systems/omo/config.nix b/makefu/1systems/omo/config.nix
index aaecebadc..ce3ffbcf3 100644
--- a/makefu/1systems/omo/config.nix
+++ b/makefu/1systems/omo/config.nix
@@ -143,7 +143,10 @@ in {
];
fileSystems = let
cryptMount = name:
- { "/media/${name}" = { device = "/dev/mapper/${name}"; fsType = "xfs"; };};
+ { "/media/${name}" = {
+ device = "/dev/mapper/${name}"; fsType = "xfs";
+ options = [ "nofail" ];
+ };};
in cryptMount "crypt0"
// cryptMount "crypt1"
// cryptMount "crypt2"