summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/filepimp.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-11-09 02:37:13 +0100
committerlassulus <lass@aidsballs.de>2015-11-09 02:37:13 +0100
commit3d7790601ef2b32bf6b72f829137fd18d9874fd3 (patch)
tree02b5af9d30d27c5ddac360ae1fa13e0e20d5c20c /makefu/1systems/filepimp.nix
parent9ff1f770f6f3703fad34ef4ce2d24116d84a5665 (diff)
parent610a3ce59c2ba0e58205305a85e9cb86e680d481 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'makefu/1systems/filepimp.nix')
-rw-r--r--makefu/1systems/filepimp.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/makefu/1systems/filepimp.nix b/makefu/1systems/filepimp.nix
new file mode 100644
index 000000000..fb1a57552
--- /dev/null
+++ b/makefu/1systems/filepimp.nix
@@ -0,0 +1,38 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ../2configs/default.nix
+ ../2configs/fs/vm-single-partition.nix
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/tinc-basic-retiolum.nix
+ ];
+ krebs.build.host = config.krebs.hosts.filepimp;
+
+ # AMD N54L
+ boot = {
+ loader.grub.device = "/dev/sda";
+
+ initrd.availableKernelModules = [
+ "usb_storage"
+ "ahci"
+ "xhci_hcd"
+ "ata_piix"
+ "uhci_hcd"
+ "ehci_pci"
+ ];
+
+ kernelModules = [ ];
+ extraModulePackages = [ ];
+ };
+
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+ networking.firewall.allowPing = true;
+}