summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-05-02 09:44:08 +0200
committermakefu <github@syntax-fehler.de>2017-05-02 09:44:08 +0200
commitf1b266e05c61710a0b4b657f5916ac84d579e358 (patch)
tree432633b6b2c5f27102ffa46b38d915af9983ec7e /lib/types.nix
parentcc8efe15822d15d0cb4315b0d0c308474ef3343f (diff)
parentd18c4022d277dd45ffc388b8f3868a42ab9592ad (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/types.nix b/lib/types.nix
index f511541bd..30de5e177 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -284,8 +284,8 @@ rec {
default = "/home/${config.name}";
};
mail = mkOption {
- type = str; # TODO retiolum mail address
- default = "${config._module.args.name}@${config.networking.hostName}.r";
+ type = nullOr str;
+ default = null;
};
name = mkOption {
type = username;