summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-02-01 13:54:09 +0100
committermakefu <github@syntax-fehler.de>2022-02-01 13:54:09 +0100
commitc564c4f0f48e6d6e889f50b520b7c512df527660 (patch)
tree540a8ed795596c2de673f1fb4326dd89a003c1a4 /lib/types.nix
parent965a6c96c3b7216bf8ca1b985f8bece6c73213c4 (diff)
parentbe042e3446905e2517b530403bacc63b6de49d34 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 318e2f237..f312b734b 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -7,7 +7,7 @@ let
mkOptionType optional optionalAttrs optionals range splitString
stringLength substring test testString typeOf;
inherit (lib.types)
- attrsOf bool either enum int listOf nullOr path str submodule;
+ attrsOf bool either enum int lines listOf nullOr path str submodule;
in
rec {
@@ -211,7 +211,7 @@ rec {
extraConfig = mkOption {
description = "Extra Configuration to be appended to the hosts file";
default = "";
- type = str;
+ type = lines;
};
port = mkOption {
type = int;