summaryrefslogtreecommitdiffstats
path: root/lass/krops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-11-05 18:20:42 +0100
committermakefu <github@syntax-fehler.de>2018-11-05 18:20:42 +0100
commit254e9e62b95951cecadd2b4800c03ef96f95b3c0 (patch)
tree6892ca816d01eb712b80af9dbd79cc6690f21752 /lass/krops.nix
parent8b57f04ff84b53742ef6a8a9677560745075ffb1 (diff)
parent100ca928ad483471d61b36bd9e977e34441d404b (diff)
Merge remote-tracking branch 'lassul.us/master'
Diffstat (limited to 'lass/krops.nix')
-rw-r--r--lass/krops.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/lass/krops.nix b/lass/krops.nix
index 4e045c6db..a898164c3 100644
--- a/lass/krops.nix
+++ b/lass/krops.nix
@@ -22,13 +22,14 @@
in {
# usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
- deploy = pkgs.krops.writeDeploy "${name}-deploy" {
+ deploy = { target ? "root@${name}/var/src" }: pkgs.krops.writeDeploy "${name}-deploy" {
source = source { test = false; };
- target = "root@${name}/var/src";
+ inherit target;
};
# usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)
test = { target }: pkgs.krops.writeTest "${name}-test" {
+ force = true;
inherit target;
source = source { test = true; };
};