summaryrefslogtreecommitdiffstats
path: root/lass/kops.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-06-07 08:24:56 +0200
committerlassulus <lass@blue.r>2018-06-07 08:24:56 +0200
commit2e7f0ada013810e577944434f42000313befe549 (patch)
treefc9c3480101d0bfcf15448bef9d1a4d1767afee9 /lass/kops.nix
parent16d306c784ce586cc72ff24f2ab65f6431f9c5d5 (diff)
l: kops -> krops
Diffstat (limited to 'lass/kops.nix')
-rw-r--r--lass/kops.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/lass/kops.nix b/lass/kops.nix
deleted file mode 100644
index 2dda0e8fb..000000000
--- a/lass/kops.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ name }: let
- inherit (import ../krebs/kops.nix { inherit name; })
- krebs-source
- lib
- pkgs
- ;
-
- source = { test }: lib.evalSource [
- krebs-source
- {
- nixos-config.symlink = "stockholm/lass/1systems/${name}/physical.nix";
- secrets = if test then {
- file = "/home/lass/stockholm/lass/2configs/tests/dummy-secrets";
- } else {
- pass = {
- dir = "${lib.getEnv "HOME"}/.password-store";
- name = "hosts/${name}";
- };
- };
- }
- ];
-
-in {
- # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
- deploy = pkgs.kops.writeDeploy "${name}-deploy" {
- source = source { test = false; };
- target = "root@${name}/var/src";
- };
-
- # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A test)
- test = pkgs.kops.writeTest "${name}-test" {
- source = source { test = true; };
- target = "${lib.getEnv "HOME"}/tmp/${name}-kops-test-src";
- };
-}