summaryrefslogtreecommitdiffstats
path: root/lass/3modules/xresources.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-18 21:24:28 +0100
committermakefu <github@syntax-fehler.de>2017-12-18 21:24:28 +0100
commitaf308642031f971bc30c5694385eb7af1e9ea618 (patch)
tree7e9e55f7d5de874a61a5d9294065a4f9749ee83e /lass/3modules/xresources.nix
parent4feafd70204f9c13500bd427d250fac60ca595ef (diff)
parent676c76dd8e0b5cbe3d1bdba49b21b1b5cfc578a1 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'lass/3modules/xresources.nix')
-rw-r--r--lass/3modules/xresources.nix58
1 files changed, 0 insertions, 58 deletions
diff --git a/lass/3modules/xresources.nix b/lass/3modules/xresources.nix
deleted file mode 100644
index 017dbff2b..000000000
--- a/lass/3modules/xresources.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-#TODO:
-#prefix with Attribute Name
-#ex: urxvt
-
-with builtins;
-with lib;
-
-
-let
-
- inherit (pkgs) writeScript writeText;
-
-in
-
-{
-
- options = {
- services.xresources.enable = mkOption {
- type = types.bool;
- default = false;
- description = ''
- Whether to enable the automatic loading of Xresources definitions at display-manager start;
- '';
- };
-
- services.xresources.resources = mkOption {
- default = {};
- type = types.attrsOf types.str;
- example = {
- urxvt = ''
- URxvt*scrollBar: false
- URxvt*urgentOnBell: true
- '';
- };
- description = ''
- Xresources definitions.
- '';
- };
- };
-
- config =
- let
- cfg = config.services.xresources;
- xres = writeText "xresources" (concatStringsSep "\n" (attrValues cfg.resources));
-
- in mkIf cfg.enable {
- services.xserver.displayManager.sessionCommands = ''
- ${pkgs.xorg.xrdb}/bin/xrdb -merge ${xres}
- '';
- environment.systemPackages = [
- (pkgs.writeDashBin "updateXresources" ''
- ${pkgs.xorg.xrdb}/bin/xrdb -merge ${xres}
- '')
- ];
- };
-}