summaryrefslogtreecommitdiffstats
path: root/lass/2configs/starcraft.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-07-17 20:22:52 +0200
committertv <tv@krebsco.de>2018-07-17 20:22:52 +0200
commit3dedfb8de4dc7e741f4db5310739884fba68b5bd (patch)
tree25e2955462d2998afe04356128f9d464d1b40b52 /lass/2configs/starcraft.nix
parent75aa3b118b6c74b2e87ccf7e3da53aa06fa7d569 (diff)
parent74698c904460db569a3c6c8355c0b25a94c98800 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/2configs/starcraft.nix')
-rw-r--r--lass/2configs/starcraft.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/lass/2configs/starcraft.nix b/lass/2configs/starcraft.nix
new file mode 100644
index 000000000..742b877e8
--- /dev/null
+++ b/lass/2configs/starcraft.nix
@@ -0,0 +1,53 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.mainUser;
+ newWine = pkgs.wineStaging;
+ #newWine = pkgs.wineStaging.overrideAttrs (old: {
+ # name = "wine-3.7";
+ # buildInputs = old.buildInputs ++ [
+ # pkgs.libuuid.bin
+ # pkgs.autoconf.out
+ # ];
+ # src = pkgs.fetchurl {
+ # url = "https://dl.winehq.org/wine/source/3.x/wine-3.7.tar.xz";
+ # sha256 = "1drbzk3y0m14lkq3vzwwkvain5shykgcbmyzh6gcb5r4sxh3givn";
+ # };
+ # postPatch = old.postPatch or "" + ''
+ # patchShebangs tools
+ # cp -r ${pkgs.fetchFromGitHub {
+ # sha256 = "0kam73jqhah7bzji5csxxhhfdp6byhzpcph6xnzjqz2aic5xk7xi";
+ # owner = "wine-staging";
+ # repo = "wine-staging";
+ # rev = "v3.7";
+ # }}/patches .
+ # chmod +w patches
+ # cd patches
+ # patchShebangs gitapply.sh
+ # ./patchinstall.sh DESTDIR="$PWD/.." --all
+ # cd ..
+ # '';
+
+ #});
+ #newWine = (import (builtins.fetchGit {
+ # url = "https://github.com/NixOS/nixpkgs";
+ # rev = "696c6bed4e8e2d9fd9b956dea7e5d49531e9d13f";
+ #}) {}).wineStaging;
+in {
+ users.users= {
+ starcraft = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ newWine
+ pkgs.winetricks
+ pkgs.mpg123
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(starcraft) NOPASSWD: ALL
+ '';
+}
+