summaryrefslogtreecommitdiffstats
path: root/lass/2configs/reaktor-krebs.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-09-04 09:05:06 +0200
committermakefu <github@syntax-fehler.de>2017-09-04 09:05:06 +0200
commit729549d15464e57e41fd143450c36274cedc84fa (patch)
treec28cfa3576c601f7f665cebc7721ef3a08311792 /lass/2configs/reaktor-krebs.nix
parent848acb85ccecbe25987bf6da45a96fc4eaaa74e9 (diff)
parentfcf59a00e2ab675cb171cbe4f21b8df73836d144 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/reaktor-krebs.nix')
-rw-r--r--lass/2configs/reaktor-krebs.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/lass/2configs/reaktor-krebs.nix b/lass/2configs/reaktor-krebs.nix
new file mode 100644
index 000000000..6b17b457d
--- /dev/null
+++ b/lass/2configs/reaktor-krebs.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+
+{
+ krebs.Reaktor.krebs = {
+ nickname = "Reaktor|krebs";
+ channels = [
+ "#krebs"
+ "#nixos-wiki"
+ ];
+ extraEnviron = {
+ REAKTOR_HOST = "irc.freenode.org";
+ };
+ plugins = with pkgs.ReaktorPlugins; [
+ sed-plugin
+ wiki-todo-add
+ wiki-todo-done
+ wiki-todo-show
+ ];
+ };
+ services.nginx.virtualHosts."lassul.us".locations."/wiki-todo".extraConfig = ''
+ default_type "text/plain";
+ alias /var/lib/Reaktor/state/wiki-todo;
+ '';
+}