summaryrefslogtreecommitdiffstats
path: root/lass/2configs/reaktor-krebs.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-09-05 23:00:23 +0200
committertv <tv@krebsco.de>2017-09-05 23:00:23 +0200
commit1436781119f92cbf431db5e817fba765b24d922a (patch)
treef8ee298cdddd02beab384b047cc1a76bd1bd26c1 /lass/2configs/reaktor-krebs.nix
parent77e9bd83e2208d1d732ef505e0e996a2440d5d7c (diff)
parent71d3f53f2bf767cfbb6e941438431d6083f304b9 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/2configs/reaktor-krebs.nix')
-rw-r--r--lass/2configs/reaktor-krebs.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/lass/2configs/reaktor-krebs.nix b/lass/2configs/reaktor-krebs.nix
new file mode 100644
index 000000000..6b17b457d
--- /dev/null
+++ b/lass/2configs/reaktor-krebs.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+
+{
+ krebs.Reaktor.krebs = {
+ nickname = "Reaktor|krebs";
+ channels = [
+ "#krebs"
+ "#nixos-wiki"
+ ];
+ extraEnviron = {
+ REAKTOR_HOST = "irc.freenode.org";
+ };
+ plugins = with pkgs.ReaktorPlugins; [
+ sed-plugin
+ wiki-todo-add
+ wiki-todo-done
+ wiki-todo-show
+ ];
+ };
+ services.nginx.virtualHosts."lassul.us".locations."/wiki-todo".extraConfig = ''
+ default_type "text/plain";
+ alias /var/lib/Reaktor/state/wiki-todo;
+ '';
+}