summaryrefslogtreecommitdiffstats
path: root/lass/2configs/git.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-09-04 09:05:06 +0200
committermakefu <github@syntax-fehler.de>2017-09-04 09:05:06 +0200
commit729549d15464e57e41fd143450c36274cedc84fa (patch)
treec28cfa3576c601f7f665cebc7721ef3a08311792 /lass/2configs/git.nix
parent848acb85ccecbe25987bf6da45a96fc4eaaa74e9 (diff)
parentfcf59a00e2ab675cb171cbe4f21b8df73836d144 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/git.nix')
-rw-r--r--lass/2configs/git.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/lass/2configs/git.nix b/lass/2configs/git.nix
index d3f5d1f39..61a352bde 100644
--- a/lass/2configs/git.nix
+++ b/lass/2configs/git.nix
@@ -34,6 +34,10 @@ let
cgit.desc = "take a rss feed and a timeout and print it to stdout";
cgit.section = "software";
};
+ nixpkgs = {
+ cgit.desc = "nixpkgs fork";
+ cgit.section = "configuration";
+ };
stockholm = {
cgit.desc = "take all the computers hostage, they'll love you!";
cgit.section = "configuration";
@@ -80,7 +84,7 @@ let
public = true;
};
- make-restricted-repo = name: { collaborators ? [], announce ? false, ... }: {
+ make-restricted-repo = name: { collaborators ? [], announce ? false, hooks ? {}, ... }: {
inherit collaborators name;
public = false;
hooks = optionalAttrs announce {
@@ -93,7 +97,7 @@ let
# TODO define branches in some kind of option per repo
branches = [ "master" "staging*" ];
};
- };
+ } // hooks;
};
make-rules =