summaryrefslogtreecommitdiffstats
path: root/lass/1systems/uriel.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-23 15:38:01 +0200
committermakefu <github@syntax-fehler.de>2015-10-23 15:38:01 +0200
commita1d05482e5527d32baef9d9343b900dee8d46694 (patch)
tree2de3ac509481799f6188620987cdf1678ea675a5 /lass/1systems/uriel.nix
parent709ebf6bbcc2e0d4644ed35cd42db47c4f2e78c5 (diff)
parent93dcfe5ad61903f90f422d9d6c97e499b240aa86 (diff)
Merge remote-tracking branch 'cloudkrebs/master'
Diffstat (limited to 'lass/1systems/uriel.nix')
-rw-r--r--lass/1systems/uriel.nix31
1 files changed, 2 insertions, 29 deletions
diff --git a/lass/1systems/uriel.nix b/lass/1systems/uriel.nix
index 62338d054..1b008cbfd 100644
--- a/lass/1systems/uriel.nix
+++ b/lass/1systems/uriel.nix
@@ -3,11 +3,10 @@
with builtins;
{
imports = [
- ../2configs/desktop-base.nix
+ ../2configs/baseX.nix
../2configs/browsers.nix
../2configs/games.nix
../2configs/pass.nix
- ../2configs/urxvt.nix
../2configs/bird.nix
../2configs/git.nix
../2configs/chromium-patched.nix
@@ -25,26 +24,9 @@ with builtins;
}
];
- krebs.build = {
- user = config.krebs.users.lass;
- target = "root@uriel";
- host = config.krebs.hosts.uriel;
- source = {
- dir.secrets = {
- host = config.krebs.hosts.mors;
- path = "/home/lass/secrets/${config.krebs.build.host.name}";
- };
- dir.stockholm = {
- host = config.krebs.hosts.mors;
- path = "/home/lass/dev/stockholm";
- };
- };
- };
-
- networking.hostName = "uriel";
+ krebs.build.host = config.krebs.hosts.uriel;
networking.wireless.enable = true;
- nix.maxJobs = 2;
hardware.enableAllFirmware = true;
nixpkgs.config.allowUnfree = true;
@@ -65,8 +47,6 @@ with builtins;
initrd.availableKernelModules = [ "xhci_hcd" "ehci_pci" "ahci" "usb_storage" ];
#kernelModules = [ "kvm-intel" "msr" ];
kernelModules = [ "msr" ];
- extraModprobeConfig = ''
- '';
};
fileSystems = {
"/" = {
@@ -93,11 +73,4 @@ with builtins;
Option "FingerLow" "60"
'';
};
-
- environment.systemPackages = with pkgs; [
- ];
-
- #for google hangout
-
- users.extraUsers.google.extraGroups = [ "audio" "video" ];
}