summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-04-04 15:23:44 +0200
committermakefu <github@syntax-fehler.de>2018-04-04 15:23:44 +0200
commit3ed84b0b8c063a294e7cb40a786fa7a15ee0e5a4 (patch)
tree569658ceb8fc90f640d7ce48357eb84a0383b494 /lass/1systems/mors/config.nix
parent1b740bf9ef32972f7242226699a75b39feeb18b2 (diff)
parent1a5b58c828409ce9bf1639f3f26ebeb142e0148a (diff)
Merge remote-tracking branch 'lass/staging/18.03' into staging
Diffstat (limited to 'lass/1systems/mors/config.nix')
-rw-r--r--lass/1systems/mors/config.nix24
1 files changed, 2 insertions, 22 deletions
diff --git a/lass/1systems/mors/config.nix b/lass/1systems/mors/config.nix
index cbb71ab24..f77bc64c2 100644
--- a/lass/1systems/mors/config.nix
+++ b/lass/1systems/mors/config.nix
@@ -170,31 +170,11 @@ with import <stockholm/lib>;
export PATH=${makeBinPath [
pkgs.bash
pkgs.coreutils
- pkgs.nix
- (pkgs.writeDashBin "is-git-crypt-locked" ''
- magic=$(dd status=none if="$1" skip=1 bs=1 count=8)
- test "$magic" = GITCRYPT
- '')
+ pkgs.nixUnstable
]}
cd ~/stockholm
export SYSTEM="$1"
- if is-git-crypt-locked ~/secrets/ready; then
- echo 'secrets are crypted' >&2
- exit 23
- else
- exec nix-shell -I stockholm="$PWD" --run 'deploy --system="$SYSTEM"'
- fi
- '';
- predeploy = pkgs.writeDash "predeploy" ''
- set -eu
- export PATH=${makeBinPath [
- pkgs.bash
- pkgs.coreutils
- pkgs.nix
- ]}
- cd ~/stockholm
- export SYSTEM="$1"
- exec nix-shell -I stockholm="$PWD" --run 'test --system="$SYSTEM" --target="$SYSTEM/var/test/" --force-populate'
+ exec nix-shell -I stockholm="$PWD" --run 'deploy --system="$SYSTEM"'
'';
};