summaryrefslogtreecommitdiffstats
path: root/lass/1systems/icarus.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-11 11:26:24 +0200
committerlassulus <lassulus@lassul.us>2017-07-12 19:09:36 +0200
commit3363a8746c9152709abcd5adbbcdc00c2df0ff39 (patch)
treea10665f6ddf735eb1ac3970f2cdb24f4cf6e4ed7 /lass/1systems/icarus.nix
parent9215b5b6880c833721caa7572b7480c7912d7fd6 (diff)
move source config from module system to 1systems/*/source.nix
Diffstat (limited to 'lass/1systems/icarus.nix')
-rw-r--r--lass/1systems/icarus.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/lass/1systems/icarus.nix b/lass/1systems/icarus.nix
deleted file mode 100644
index 13c517e3b..000000000
--- a/lass/1systems/icarus.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ config, pkgs, ... }:
-
-with import <stockholm/lib>;
-{
- imports = [
- ../.
- ../2configs/retiolum.nix
- ../2configs/hw/tp-x220.nix
- ../2configs/git.nix
- ../2configs/exim-retiolum.nix
- ../2configs/baseX.nix
- ../2configs/browsers.nix
- ../2configs/programs.nix
- ../2configs/fetchWallpaper.nix
- ../2configs/backups.nix
- ../2configs/games.nix
- ];
-
- krebs.build.host = config.krebs.hosts.icarus;
-
- boot = {
- loader.grub.enable = true;
- loader.grub.version = 2;
- loader.grub.device = "/dev/sda";
- loader.grub.efiSupport = true;
-
- initrd.luks.devices = [ { name = "luksroot"; device = "/dev/sda3"; } ];
- initrd.luks.cryptoModules = [ "aes" "sha512" "sha1" "xts" ];
- initrd.availableKernelModules = [ "xhci_hcd" "ehci_pci" "ahci" "usb_storage" ];
- };
- fileSystems = {
- "/" = {
- device = "/dev/mapper/pool-root";
- fsType = "btrfs";
- options = ["defaults" "noatime" "ssd" "compress=lzo"];
- };
- "/boot" = {
- device = "/dev/sda2";
- };
- #"/bku" = {
- # device = "/dev/mapper/pool-bku";
- # fsType = "btrfs";
- # options = ["defaults" "noatime" "ssd" "compress=lzo"];
- #};
- "/home" = {
- device = "/dev/mapper/pool-home";
- fsType = "btrfs";
- options = ["defaults" "noatime" "ssd" "compress=lzo"];
- };
- "/tmp" = {
- device = "tmpfs";
- fsType = "tmpfs";
- options = ["nosuid" "nodev" "noatime"];
- };
- };
-
- services.udev.extraRules = ''
- SUBSYSTEM=="net", ATTR{address}=="08:11:96:0a:5d:6c", NAME="wl0"
- SUBSYSTEM=="net", ATTR{address}=="f0:de:f1:71:cb:35", NAME="et0"
- '';
-}