summaryrefslogtreecommitdiffstats
path: root/lass/1systems/dishfire/physical.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-06-19 09:22:42 +0200
committerjeschli <jeschli@gmail.com>2018-06-19 09:22:42 +0200
commit8eca9165ce6ffaba1076a916bfa475eb935f0a6f (patch)
treeb2339ecdb48bd1135a1352b9993732ad0e35c02c /lass/1systems/dishfire/physical.nix
parent05c8cf3df5f6166c21dfd2dc316bf5de957dce94 (diff)
parentc19baeee138f9455ef570e609c045d312d6cc0f4 (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'lass/1systems/dishfire/physical.nix')
-rw-r--r--lass/1systems/dishfire/physical.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/lass/1systems/dishfire/physical.nix b/lass/1systems/dishfire/physical.nix
new file mode 100644
index 000000000..64e3904e0
--- /dev/null
+++ b/lass/1systems/dishfire/physical.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+{
+ imports = [
+ ./config.nix
+ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/vda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "ehci_pci"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_blk"
+ ];
+
+ fileSystems."/" = {
+ device = "/dev/mapper/pool-nix";
+ fsType = "ext4";
+ };
+
+ fileSystems."/srv/http" = {
+ device = "/dev/pool/srv_http";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/vda1";
+ fsType = "ext4";
+ };
+ fileSystems."/bku" = {
+ device = "/dev/pool/bku";
+ fsType = "ext4";
+ };
+}