summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/pass-otp/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-04-26 21:06:17 +0200
committermakefu <github@syntax-fehler.de>2018-04-26 21:06:17 +0200
commit87b1aa3cdd796238ecbf61d3fcd5fcc08563aa82 (patch)
treeedf59f73bd0c61beb1a5e19f3661310031e7c5f5 /krebs/5pkgs/simple/pass-otp/default.nix
parent309124175425cb7abd6dad166f485ae832435562 (diff)
parent0b9727b3ad324b1d1f6a8db4181be546eb5ec397 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'krebs/5pkgs/simple/pass-otp/default.nix')
-rw-r--r--krebs/5pkgs/simple/pass-otp/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/pass-otp/default.nix b/krebs/5pkgs/simple/pass-otp/default.nix
new file mode 100644
index 000000000..33411180a
--- /dev/null
+++ b/krebs/5pkgs/simple/pass-otp/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchFromGitHub, oathToolkit }:
+stdenv.mkDerivation rec {
+ name = "pass-otp-${version}";
+ version = "1.1.0";
+
+ src = fetchFromGitHub {
+ owner = "tadfisher";
+ repo = "pass-otp";
+ rev = "v${version}";
+ sha256 = "1cgj4zc8fq88n3h6c0vkv9i5al785mdprpgpbv5m22dz9p1wqvbb";
+ };
+
+ buildInputs = [ oathToolkit ];
+
+ patchPhase = ''
+ sed -i -e 's|OATH=\$(which oathtool)|OATH=${oathToolkit}/bin/oathtool|' otp.bash
+ '';
+
+ installPhase = ''
+ make PREFIX=$out install
+ '';
+
+ meta = with stdenv.lib; {
+ description = "A pass extension for managing one-time-password (OTP) tokens";
+ homepage = https://github.com/tadfisher/pass-otp;
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ jwiegley tadfisher ];
+ platforms = platforms.unix;
+ };
+}