summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/hashPassword/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-31 10:47:29 +0200
committermakefu <github@syntax-fehler.de>2015-08-31 10:47:29 +0200
commit2eb8bcf9d1c293a8b28730c9a12d9a857c5a43a7 (patch)
treec8a1d55a148e59f51a400e0d5dc11780d4e4005c /krebs/5pkgs/hashPassword/default.nix
parent0acd7f23e1e3adf4bf1427f186a7bf5505ff910d (diff)
parent83f06535de527c7470f8ff9c8b5e3a4632cf7cb9 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/5pkgs/hashPassword/default.nix')
-rw-r--r--krebs/5pkgs/hashPassword/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/krebs/5pkgs/hashPassword/default.nix b/krebs/5pkgs/hashPassword/default.nix
new file mode 100644
index 000000000..a10340cc4
--- /dev/null
+++ b/krebs/5pkgs/hashPassword/default.nix
@@ -0,0 +1,16 @@
+{ lib, pkgs, ... }:
+
+pkgs.writeScriptBin "hashPassword" ''
+ #! /bin/sh
+ # usage: hashPassword
+ set -euf
+
+ export PATH=${lib.makeSearchPath "bin" (with pkgs; [
+ coreutils
+ mkpasswd
+ openssl
+ ])}
+
+ salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
+ exec mkpasswd -m sha-512 -S "$salt"
+''