summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/repo-sync.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-03-06 20:21:02 +0100
committerlassulus <lassulus@lassul.us>2018-03-06 20:21:02 +0100
commit995d1b0c7cd42966651ca5d5d799b2aad219a978 (patch)
treeb1dd9a8c9cf5d0a4dd560835c2d62d4b41c7cff5 /krebs/3modules/repo-sync.nix
parent58a21e21e262c6edea2aefff0d8ca772a7e3ea70 (diff)
parent2934d4524bcbae13043d684a27597c8b08c0851b (diff)
Merge remote-tracking branch 'prism/tv'prism/staging/tv
Diffstat (limited to 'krebs/3modules/repo-sync.nix')
-rw-r--r--krebs/3modules/repo-sync.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/krebs/3modules/repo-sync.nix b/krebs/3modules/repo-sync.nix
index b2e3aa7c5..45d9d81c3 100644
--- a/krebs/3modules/repo-sync.nix
+++ b/krebs/3modules/repo-sync.nix
@@ -18,10 +18,10 @@ let
type = types.attrsOf (types.submodule ({ config, ... }: {
options = {
origin = mkOption {
- type = types.git-source;
+ type = types.source-types.git;
};
mirror = mkOption {
- type = types.git-source;
+ type = types.source-types.git;
};
};
config = {
@@ -31,7 +31,7 @@ let
}));
};
latest = mkOption {
- type = types.nullOr types.git-source;
+ type = types.nullOr types.source-types.git;
default = null;
};
timerConfig = mkOption {